Back to overview
Resolved

Updating website

May 12, 2026 at 4:00pm UTC  –  May 12, 2026 at 4:18pm UTC
Affected services
verivoucher.vylixz.com

Resolved
May 12, 2026 at 4:18pm UTC

Maintenance ended

Updated
May 12, 2026 at 4:18pm UTC

Maintenance done

Created
May 12, 2026 at 4:00pm UTC

There will be a update on the website, hang tight!